Alan's sysadmin Blog

Working smarter not harder

Public Folders Fail to Replicate between 2007 and 2010

Posted by Alan McBurney on December 20, 2010


I have just migrated a company from a mixed 2003 & 2007 environment to 2010.

2003 server removed successfully without issue, however when trying to add the 2010 server as a public folder replica the issues began.

Lots of 1020 MSExchangeStoreDriver and 3091 Replication Errors in the event logs

Finally tracked the issue down to the server object in First Administrative Group in ADSIEDIT.

Open adsiedit and check if there any objects in

CN=Servers,CN=Fist administrative group,CN=Administrative Groups,CN=Erste Organisation,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=local. Is the container “CN=Servers”

If servers is empty, then delete it.

Full blog post available at
http://get-exchange.blogspot.com/2009/11/public-folder-mayhem-exchange-2010.html?showComment=1260569369909#c8199449617092465069

Advertisements

2 Responses to “Public Folders Fail to Replicate between 2007 and 2010”

  1. Carroll B. Merriman said

    Great Post, Thx! Thank you for sharing this!

  2. Clive said

    Gotta watch out for those Fist Administrators!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: